Topic: Can't Fling Anymore!

Recently I ran into a problem where the flingo desktop application doesnt fling to my Vizio Tv anymore. I havent used it for 2 weeks. The last time I used it (2 weeks ago), it worked perfectly. Now I can't see anything I fling in the queue, after a few "resets to factory default", reinstalling flingo and computer restarts I still cant fling files to the TV.  I also tried the flingo demo tv thing, and that too doesn't receive the files I flung(except Big Buck Bunny). I'm not sure what has gone wrong.

Big Buck Bunny is the only thing that works, but when I look at discovered devices it says:

We discovered the following Flingo-enabled devices in your network:

    * Vizio generic flat panel LCD named Vizio DX
    * Vizio generic flat panel LCD named default ZU
    * Vizio generic flat panel LCD named VZHD
    * Flingo Web Demo named cafec0ffeecafec0ffeecafec0ffeecafec0ffee AX
    * Vizio generic flat panel LCD named VIZIO DX

I have no clue how to remove all these extra ones, I guess it made a new one everytime i reset the tv, but the one Im on now is the last one "VIZIO DX".

Does anyone have a solution to this problem?

Edit:  I have reset almost everything that I could possibly reset including factory defaulting my router and modem, as well as clean installing windows on a new partition. But those list of devices remain there, so it makes me wonder where this information is being stored, because my tv is powered off and disconnected the power outlet. It seems like once the tv connects once, the data is then stored on one of flingo's servers or something and is linked to my IP. That's why I cant get rid of any of them. I'm wondering if this is related to the problem.

Last edited by ShadowVizio (2011-02-18 21:44:44)


Re: Can't Fling Anymore!

Desktop fling seems to be broken..  At least on the Mac.  Worked great as of a few days ago.  Guess I'll need to actually carry my laptop into the other room..  Dammit that makes me feel old school.


Re: Can't Fling Anymore!

Do you still have this problem?  I have written a lot of unit tests for the backend to weed out any problems.  Fixed a couple of bugs.

The problem with having multiple names appear in the lookup is disconcerting.  This can occur if the TV is unable to save state (e.g., Flash SharedObjects in the firmware is not working).  One way to test this is to turn off the TV and turn it back on then run


Does a new device appear in the lookup every time you do this?

When a new name occurs, it seems that state is being lost.  The TV thinks it is a new TV.  This can occur if the TV is reset to factory defaults or if a firmware update for some reason clears Flash SharedObjects.

You can clear all the devices from the network using


The call is restricted so that random websites cannot wipe out state on your network, so you have to do it from somewhere that won't send a referer URI.  For example, if you cut and paste the URL into the browser rather than clicking on the link, it should clear all devices from the network.