1

Topic: Problem playing youtube videos on Vizio Tv

I have a problem playing videos from youtube on my tv. It only plays the big bunny video. Each time i sent a youtube video too my queue it says "Video Playback Error" when I try too play it. I would like too know why it does that and I have a Vizio E322VL LCD HDTV. Also it was hard for me too understand this flingo thing for the tv. The only way I was able too send videos' too the tv was by doing that embed code generator thing. Because yall have showed how too do it on the chrome but not on the internet explorer. Its way different in internet explorer and I can you tell me how I can do it easier like how yall do it on chrome version???

2

Re: Problem playing youtube videos on Vizio Tv

this is a crock - i can't get it to work

3

Re: Problem playing youtube videos on Vizio Tv

I've tried so many things and I can not get it to work either.

4

Re: Problem playing youtube videos on Vizio Tv

Julio2010 wrote:

I have a problem playing videos from youtube on my tv. It only plays the big bunny video. Each time i sent a youtube video too my queue it says "Video Playback Error" when I try too play it.

Sounds like you went to greater extent than most people to try to get it to work, and for that I thank you.  I have to say I'm sorry if the instructions.  They are not good enough.  I believe providing better instructions is the lowest-hanging fruit to get people to use fling, and I'm editing it in another window while I am writing to you.

I assure that today is actually the highest traffic that fling has ever had and I measure it by number of videos that are completely played.

Thank you for providing so much information.   The embed code generator does not use the exact same process as the bookmarklet, and vizio has finicky firmware.  If we can isolate the problem, I would like to try, but first let's see if it works when you use the bookmarklet.

how I can do it easier like how yall do it on chrome version???

If the bookmark bar is not visible then click on the wrench at the right-end of the screen.  Select "bookmarks" and then select "show bookmarks bar."  Once the bookmarks bar is visible, you should be able to drag-and-drop the "fling" button on the flingo.org homepage to your bookmarks bar.

--Dave

5

Re: Problem playing youtube videos on Vizio Tv

tennie wrote:

this is a crock - i can't get it to work

Please be more specific.

6

Re: Problem playing youtube videos on Vizio Tv

lin04 wrote:

I've tried so many things and I can not get it to work either.

What browser are you using?
Were you able to install the bookmarklet?
What device or TV are you using?  If Vizio, did you start "Web Videos"?
Did the video appear in your queue when you clicked on "fling" from the bookmarks bar?
Did it fail when played?

--Dave

7

Re: Problem playing youtube videos on Vizio Tv

I added instructions on how to turn on the bookmarks bar when you try to drag the bookmarks bar on flingo.org.  Hopefully this will make it easier to people to install the fling bookmark.

The instructions are specific to the user's browser for Chrome, Firefox, and IE on Windows and Chrome, Firefox and Safari on Mac.

--Dave

8

Re: Problem playing youtube videos on Vizio Tv

Dave,

I'm having the same issue with videos added from YouTube on desktop using IE & Chrome. Some videos do play, but not the ones I really want to watch.

I get video playback error in Vizio Tv (e422va). I can see the thumbnail and the video gets added correctly to web videos.
Please advise.

Thanks in advance.

9

Re: Problem playing youtube videos on Vizio Tv

Thank Ignacio!

Ignacio has agreed to help me by taking on the task of improving the robustness of fling to a variety of encodes.  One of the problems we have is that not all encodes play on all devices and manufacturers have a habit of modifying their hardware (chipset, etc.) without providing us with a unit for certification.  Rather than requiring certification for every model, we have decided to have each TV attempt to play available encodes of each video and remember which types of encode work, and try the ones likely to work first.  This will be quite helpful for Vimeo and Youtube which offer many encodes of most of their videos.

This will be pushed soon and will require no updates for users.  I'll post again when this has been done.

--Dave
P.S. I am looking for any other engineers that want to help improve fling!

10

Re: Problem playing youtube videos on Vizio Tv

Thanks Dave! Keep up the good work!

I just love this feature. Let us know how I can evangelize it!

11

Re: Problem playing youtube videos on Vizio Tv

I fling regularly to my Vizio.   I flung just now from Internet Explorer from youtube and it played.  I need more information to help you.
 

The only way I was able too send videos' too the tv was by doing that embed code generator thing.

Were you able to install the bookmarklet?  If not then what happened when you tried?  What version of browser are you using?

I have a problem playing videos from youtube on my tv. It only plays the big bunny video. Each time i sent a youtube video too my queue it says "Video Playback Error"

How are you entering URLs in to the embed code generator?

I have a Vizio E322VL LCD HDTV.

I don't have this model in my lab, but I do have a Vizio E3D420VX and a SV422XVT.  It works on bot of these TVs using both t he bookmarklet and the embed code.  I did notice that many older encodes would not play on the E-series TV that do play on the SV422XVT.  Could you try flinging videos from http://youtube.com/music ?  Most of these are newer.  I'd be interested in whether these encodes play on your TV.  Could you try a number of different youtube videos and send the URLs for those that work and don't work?  I could then download the encodes for each to see how they are different.  Since youtube, vimeo, etc. provide multiple encodes, some of the problems may be solved by having the TV pick a different encode.  If this is the case then the only changes are on my end to update the encode profile for your TV model.

Because yall have showed how too do it on the chrome but not on the internet explorer. Its way different in internet explorer and I can you tell me how I can do it easier like how yall do it on chrome version???

I have Internet Explorer.  Internet Explorer has a notion of a "favorites bar" which isn't visible by default.  If you click on the orange "FLING" button on flingo.org, it should provide instructions specific to Internet Explorer.  This is what it says in my Internet Explorer browser window:

Drag to your favorites bar.  If the bookmarks bar (a.k.a., favorites bar) is not visible in Internet Explorer then right-click an open space to the right of the New tab button, and then select Favorites bar.

Does this apply to you?
--Dave

12

Re: Problem playing youtube videos on Vizio Tv

I cannot play these videos on my Vizio E422VA. Please tell me why...

http://youtu.be/EOyL0RVUOMM

13

Re: Problem playing youtube videos on Vizio Tv

Anything that has a rating restriction will not play. I need to generate an appropriate error message for this case.

--Dave

14

Re: Problem playing youtube videos on Vizio Tv

I am also unable to fling anything to my Vizio TV.  We have a model E3D420VX, and we use a MacBook Pro running Chrome.  We were able to fling just fine for a while and then one day it just stopped working.  It says "We found no fling-enabled devices in your network."  I don't know how to tell if the MacBook and the TV are on the same network.  They should be, but the TV is plugged into Ethernet in our house, and the MacBook is connected to our WiFi.  Any help would be appreciated.

15

Re: Problem playing youtube videos on Vizio Tv

"no devices in network" is almost always due to being connected to the wrong network, or you are connected via a network that has multiple public IP addresses.  The latter is fixed by ensuring that your router / DSL modem / NAT / firewall uses a single public IP address.

--Dave

16

Re: Problem playing youtube videos on Vizio Tv

Hi, I've been flinging successfully on my Vizio since I started about a year ago.  All of a sudden, I'm unable to play my flings.  The videos show up in the queue, but when I click to play them they stall.  This used to happen for videos that were queued for more than a day, but then that was fixed.  Now, it doesn't matter if I fling them five minutes ago or longer... 

Any advice?

I own a Vizio SV472XVT and watching videos via the Web Video app.  I have already tried uninstalling-reinstalling the app.

Thanks,
Neal

17

Re: Problem playing youtube videos on Vizio Tv

I have a Sony VAIO and I use Firefox version 19.0. I just today figured out how to use the Fling bookmarklet. I succeeded in flinging several videos from crunchyroll and youtube to my VIZIO TV (which is a M3D470KD 47-inch). They appeared in the queue under my Web Videos app, but the first few times I tried to play the ones from crunchyroll I got the message "Video Playback Error". Some of those from youtube played and some did not. I suspect that the ones that played were mp4s and the others flvs or other. I did finally get one from crunchyroll to play. Is there some way to make it more reliable?

Last edited by Soapm (2013-02-26 14:37:17)

18

Re: Problem playing youtube videos on Vizio Tv

Try again.  We just pushed some fixes.

--Dave