1

Topic: Stream to Vizio TV crashes

I have a Vizio E3D420vx, and I've been using the Win desktop app to fling to it.  I get frequent crashes when flinging HD video.
Here's what happens:  I'm watching a video when all of a sudden the picture gets stuck on a frame and the audio continues.  When I stop or otherwise go back to the queue, the video I was watching is missing and I have to re-fling it from my desktop (which means running up the stairs.  Too much exercise).  This generally happens with longer videos (over 30 minutes)
I was using the older precompiled version, but after it happened a few times I got the latest build from github and built it.  I'm not seeing anything in my router's logs to indicate an issue there, my videos are encoded according to your recommendations and my firewalls allow all local traffic.

Any ideas?

2

Re: Stream to Vizio TV crashes

Oh, my desktop is a Win7 Phenom II, and my router is a Buffalo WZR-HP-G300NH running OpenWrt Backfire 10.03.1

3

Re: Stream to Vizio TV crashes

Aiya!!  I feel you.

The video disappears from your queue because the video is considered "played" shortly after it begins playback.  We have long-since designed around this by adding a notion of history, but we have yet to get Vizio to upgrade to a newer user interface.

I'm watching a video when all of a sudden the picture gets stuck on a frame and the audio continues.

This looks very much like a problem with the video pipeline.   A lot of TVs have poor playback behavior for unexpected encode parameters on an MP4.  We do not have the ability to modify the video pipeline inside the chip.

--Dave